Hi,

helpers/basic_auth/NCSA/crypt_md5.cc
there's an XXX hinting at some uncertainty. Is it stale or is there some doubts?

helpers/basic_auth/RADIUS/basic_radius_auth.cc and elsewhere
+#if HAVE_NETTLE_MD5_H
+#include <nettle/md5.h>
+#endif
I know that the conventions mandate to #if-guard this include, but
since it is mandatory and we do not provide an alternate
implementation, does it make sense? It'll break regardless.

helpers/basic_auth/RADIUS/radius.h
#define AUTH_VECTOR_LEN        MD5_DIGEST_SIZE // 16
I'd suggest to use a c-style comment for clarity.


Food for thought: what about c++-wrapping the nettle API, at lieast
for MD5 which we use extensively?

Apart from these thoughts, looks good to me



On Mon, Mar 17, 2014 at 10:12 AM, Amos Jeffries <squ...@treenet.co.nz> wrote:
> On 17/03/2014 10:11 p.m., Amos Jeffries wrote:
>> This is the patch making libnettle mandatory dependency and dropping
>> completely the bundled MD5 implementation.
>>
>
> Or to be exact this patch is :-P
>
> Amos



-- 
    Francesco

Reply via email to