Author: adrian
Date: Thu Jul 19 03:18:15 2012
New Revision: 238608
URL: http://svn.freebsd.org/changeset/base/238608

Log:
  Use HAL_NUM_RX_QUEUES rather than a magic constant.

Modified:
  head/sys/dev/ath/if_athvar.h

Modified: head/sys/dev/ath/if_athvar.h
==============================================================================
--- head/sys/dev/ath/if_athvar.h        Thu Jul 19 02:25:14 2012        
(r238607)
+++ head/sys/dev/ath/if_athvar.h        Thu Jul 19 03:18:15 2012        
(r238608)
@@ -410,7 +410,7 @@ struct ath_softc {
        uint32_t                sc_bssidmask;   /* bssid mask */
 
        struct ath_rx_methods   sc_rx;
-       struct ath_rx_edma      sc_rxedma[2];   /* HP/LP queues */
+       struct ath_rx_edma      sc_rxedma[HAL_NUM_RX_QUEUES];   /* HP/LP queues 
*/
        int                     sc_rx_statuslen;
        int                     sc_tx_desclen;
        int                     sc_tx_statuslen;
_______________________________________________
svn-src-head@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/svn-src-head
To unsubscribe, send any mail to "svn-src-head-unsubscr...@freebsd.org"

Reply via email to