On Sat, Aug 24, 2013 at 12:24:59PM +0000, Andre Oppermann wrote:
A> Author: andre
A> Date: Sat Aug 24 12:24:58 2013
A> New Revision: 254779
A> URL: http://svnweb.freebsd.org/changeset/base/254779
A> 
A> Log:
A>   Avoid code duplication for mbuf initialization and use m_init() instead
A>   in mb_ctor_mbuf() and mb_ctor_pack().

m_init() is inline, but it calls m_pkthdr_init() which isn't inline. It
might be that compiler inline it due to m_pkthdr_init() living in the same
file as mb_ctor_mbuf() and mb_ctor_pack(), but not sure.

m_pkthdr_init() zeroes much more than deleted code did. Some zeroing
operations are definitely superfluous job.

The change is definitely not an no-op change. It might have pessimized
the mbuf allocation performance.

-- 
Totus tuus, Glebius.
_______________________________________________
svn-src-head@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/svn-src-head
To unsubscribe, send any mail to "svn-src-head-unsubscr...@freebsd.org"

Reply via email to