Hi all,

I could get used to the formNoun naming convention for the mutable versions of 
the methods. 

I would suggest the following changes:

Remove the parameter label from symmetricDifference() and 
formSymmetricDifference() to be consistent with the other methods. 

Consider renaming:
subtracting / subtract 

to: 
difference / formDifference

in order to keep the API consistent. 

Thanks

> On Mar 24, 2016, at 5:35 PM, Xiaodi Wu via swift-evolution 
> <swift-evolution@swift.org> wrote:
> 
> Much improved, IMO. A few thoughts:
> * typo in "formSymmetricDifference"
> * I don't know about the preposition "from" in "form symmetric difference 
> from" (also, inconsistent, because you don't have "form union with")
> * "form" is fine, but scans similarly to "from" when reading quickly
> 
>> On Thu, Mar 24, 2016 at 3:41 PM Dave Abrahams via swift-evolution 
>> <swift-evolution@swift.org> wrote:
>> 
>> Just an update:
>> 
>> The naming guidelines working group went back into negotiation over
>> the shape of SetAlgebra (and thus, Set and OptionSet) for
>> Swift 3, and reached a new consensus.  We intend to bring forward a
>> proposal for the API shown here:
>> 
>>   http://dabrahams.github.io/swift-naming/SetAlgebra-Math.html
>> 
>> and to update the guidelines to suggest using the "form" prefix to
>> create a verb phrase for a mutating method when the operation is
>> fundamentally non-mutating and described by a noun.
>> 
>> Regards,
>> 
>> --
>> Dave
>> 
>> _______________________________________________
>> swift-evolution mailing list
>> swift-evolution@swift.org
>> https://lists.swift.org/mailman/listinfo/swift-evolution
> _______________________________________________
> swift-evolution mailing list
> swift-evolution@swift.org
> https://lists.swift.org/mailman/listinfo/swift-evolution
_______________________________________________
swift-evolution mailing list
swift-evolution@swift.org
https://lists.swift.org/mailman/listinfo/swift-evolution

Reply via email to