> It sounds good, thanks for you suggestions @Vladimir, @Patrick and @Brent.
> 
> I've just updated the proposal: 
> https://github.com/luish/swift-evolution/blob/more-lenient-subscripts/proposals/nnnn-more-lenient-collections-subscripts.md#detailed-design
> 
> - Luis

Hmm. If you're going with `checking` for one of them, perhaps the other should 
be `clamping` (for the analogous method on `Range`, which you might want to use 
in the implementation of that subscript). That would create a nicely matched 
pair:

        array[checking: 0..<10]
        array[clamping: 0..<10]

-- 
Brent Royal-Gordon
Architechies

_______________________________________________
swift-evolution mailing list
swift-evolution@swift.org
https://lists.swift.org/mailman/listinfo/swift-evolution

Reply via email to