Comment #3 on issue 1919 by Vinzent.Steinberg: unify behavior of var() and symbols()
http://code.google.com/p/sympy/issues/detail?id=1919

Sorry for the first sentence. :) It should read: 'See the corresponding source code.'

The only thing that is different is indeed the default value of the each_char flag:

symbols('alpha')
[a, l, p, h, a]
var('alpha')
alpha

Theoretically there should be not a lot of code duplication, because I refactored both functions a long time ago to avoid this (var() actually calls symbols()). I'm not sure about merging both functions into one, it is convenient to have both.

Looking at the source code:

kwargs['each_char'] = False

This should be fixed to respect a possible user-set keyword.

--
You received this message because you are listed in the owner
or CC fields of this issue, or because you starred this issue.
You may adjust your issue notification preferences at:
http://code.google.com/hosting/settings

--
You received this message because you are subscribed to the Google Groups 
"sympy-issues" group.
To post to this group, send email to sympy-iss...@googlegroups.com.
To unsubscribe from this group, send email to 
sympy-issues+unsubscr...@googlegroups.com.
For more options, visit this group at 
http://groups.google.com/group/sympy-issues?hl=en.

Reply via email to