Comment #18 on issue 2308 by asmeurer: Should we rename primitive()? (and Expr.primitive() should call primitive())
http://code.google.com/p/sympy/issues/detail?id=2308

Well, Chris inadvertently brought up a good point. (2*x/3 + 4*y/9).primitive() => (2/9, 2*y + 3*x) is wrong. It should be (1, 2*x/3 + 4*y/9) like primitive(2*x/3 + 4*y/9). This is just the mathematical definition. Other functions like as_coeff_whatever might change depending on what is useful, but primitive() should stay to its strict mathematical definition.

So let's just delete Add.primitive and create a Expr.primitive() that is a wrapper for primitive(), just like Expr.simplify().

And also consider renaming it to primpart() or as_primitive() or as_content_primitive() or something.

--
You received this message because you are subscribed to the Google Groups 
"sympy-issues" group.
To post to this group, send email to sympy-issues@googlegroups.com.
To unsubscribe from this group, send email to 
sympy-issues+unsubscr...@googlegroups.com.
For more options, visit this group at 
http://groups.google.com/group/sympy-issues?hl=en.

Reply via email to