> :By the way 'softc' is generally for device drivers, you might prefer > :something like bfdd (d for descriptor). > > There's be a whole lot of bikeshedding about this topic, I would prefer > not to change it for now.
It should be changed. mpi is right. That variable naming should only refer per-instance state of a driver, direct out of autoconf. It should never appear far away from autoconf. It would be like declaring char *i, and int p.
