On Wed, Nov 16, 2022 at 12:47:46PM +0100, Claudio Jeker wrote:
> A aspa-set is defined like this:
> aspa-set {
> source-as 1 transit-as { 5 }
> source-as 2 expires 1668181648 transit-as { 3 4 }
> source-as 5 transit-as { 1 2 allow inet 7 allow inet6 }
> }
bikeshed.com
I'd argue s/source-as/customer-as/ and s/transit-as/provider-as/
because bgpd.conf(5)'s transit-as already has a defined meaning: any ASN
left of the origin AS in the AS_PATH. In ASPA the customer-as and
provider-as are adjacent (if I understand the voodoo correctly).
> As usual more than one aspa-set can be used and these sets will all be
> merged into one table.
>
> Since this is already a lot of code to fiddle with various rb trees and
> doing various realloc games I would like to get this reviewed and
> committed before adding a lot more code.
>
> Once this is in rpki-client can be adjusted to produce an aspa-set in the
> openbgpd output.
Nice
Kind regards,
Job