On Thu, Jan 05, 2023 at 08:32:44PM +1000, David Gwynne wrote:
>
>
> > On 5 Jan 2023, at 18:56, Alexandr Nedvedicky <[email protected]> wrote:
> >
> > Hello,
> >
> > On Wed, Jan 04, 2023 at 09:36:38PM +1000, David Gwynne wrote:
> >> and "stp" for pf_state ** variables.
> >>
> > I agree with established naming conventions.
> >
> > I'm also fine with keeping some exceptions such as `a` and `b`
> > in pf_state_compare_id(), local variables `tail`, `head`
> > in pf_states_{clr, get}() and pf_purge_expired_states().
> > I'm also fine with leaving static variable `cur` unchanged.
> >
> > is there any reason we still keep `pf_state **sm` argument
> > in pf_test_rule()? the same in pf_create_state(). Is it intended?
>
> there were a bunch of other arguments that ended with m. happy to change it
> to **stp though. we can always do another sweep for other types.
>
I would change those occurrences to stp. my point is that we don't
expect pf_test_rule() to return matching state.
with those tweaks diff is OK
thanks and
regards
sashan