One little thing because it's an obvious problem:

>    gchar     *(*get_mime_type)       (ThunarxFileInfo *file_info);
>    gboolean   (*has_mime_type)       (ThunarxFileInfo *file_info,
>                                       const gchar     *mime_type);
> -
> +  void       (*set_emblem)          (ThunarxFileInfo *file_info,
> +                                     const gchar     *emblem_name);
>    gboolean   (*is_directory)        (ThunarxFileInfo *file_info);
>  

You can't do this, because it breaks binary compatibility with any
existing plugins.  You should rename the "reserved0" declaration in the
struct to your new vfunc to keep the struct the same size and keep all
the existing members in the same positions.

Otherwise, as YAP said, you should file a feature request on bugzilla
and attach the patch.

        -brian
_______________________________________________
Thunar-dev mailing list
Thunar-dev@xfce.org
http://foo-projects.org/mailman/listinfo/thunar-dev

Reply via email to