Hello,

First of all thank you very much for Tinc.

I have been using 1.0.24 under Debian & Alpine Linux 32 bit using 'BindToAddress' in tinc.conf without any issues to bind to an IPv6 ULA Address.

With 1.1pre10 'BindToAddress' in tinc.conf on the client machines fails with:
==============================================================================
tincd 1.1pre10 (Jun  7 2014 21:38:38) starting, debug level 5
/dev/net/tun is a Linux tun/tap device (tun mode)
Can't bind to fxxx:xxxx:xxx::x port xxx/tcp: Cannot assign requested address
Unable to create any listening socket!
Closing connection with proxy ((null))
Executing script tinc-down
Script tinc-down exited with non-zero status 1
Terminating
==============================================================================

tinc.conf:

Name = client
ConnectTo = router
BindToAddress = fxxx:xxxx:xxx::x xxx
ExperimentalProtocol = yes
AddressFamily = ipv6
PrivateKeyFile = /etc/tinc/vpn/rsa_key.priv
KeyExpire = 1200
PingInterval = 30

------------------------------------------------------------------------------
tinc-up:

ip -6 link set $INTERFACE up mtu 1280
ip -6 addr add $ULA_IP/64 dev $INTERFACE
ip6tables ............

Setting 'ListenToAddress' fails with the same error.

On the KVM router there is no problem binding to a globally routable ip6 address & also a private ip4. The client machines (LXC & OpenVZ containers) both fail with the above error.

1.1pre10 clients run ok listening on all available ipv6 addresses - it would be nice to bind tinc to a private ipv6 address as I can with 1.0.24.

1.1pre10 does seem to run around 20% faster with the new protocol.

Stuart.

_______________________________________________
tinc mailing list
[email protected]
http://www.tinc-vpn.org/cgi-bin/mailman/listinfo/tinc

Reply via email to