Hi Stephen,

Thank you for your nice work.

> Concretely, I think we should make the following changes.
> 1. Replace `length` with `TLSCiphertext.length` in the definition of 
> `TLSCiphertext`.

I agree.

> 2. Replace `Hash.length` with `hash_length` throughout (9 instances).

I agree.

> 3. Change the definition of `select`'s `case` statements to have 0 or more 
> fields (types and names) and remove the optional label.
> 4. Change the `select` example to match the new definition.

I agree if this means 1 or more. (See below)

> 5. Change `Handshake` by adding field names to each `case` statement. (These 
> could all be `body` or they could be unique.)

Would you show me a concrete definition?

> Remove the `body` label.

I agree.

> 6. Delete the `Empty` structure and replace both current uses with the 
> comment `/* Empty */`.

Empty has a long story.

I proposed None (namely Empty) first but it was not accepted:

        https://github.com/tlswg/tls13-spec/issues/630

But when we discussed EarlyDataIndication, this idea came back:

        https://github.com/tlswg/tls13-spec/issues/861

So, people would want to avoid removing Empty again.

--Kazu

_______________________________________________
TLS mailing list
TLS@ietf.org
https://www.ietf.org/mailman/listinfo/tls

Reply via email to