I've pushed a bit more work on the status/commit dialog. I spent some time cleaning up variable names and providing enumerations for the file model fields. That made the code a lot more readable, to make it easier for others to contribute.
I then added support for 'partially rejected' files in the file treeview. The gtk.CellRendererToggle() class has two states. There's 'active' which sets the check mark on or off. Then there's an 'inconsistent' state which changes the check mark to a short line. This seems to match pretty closely to our purposes so I've wired it up. I'm not convinced anymore we need to strikethrough the diff headers in the diff view when the entire file is rejected since there are two visualizations already: the file will be 'unchecked' in the file list and it's diff hunks will be invisible if 'show rejected' is disabled (it is disabled by default). I'm still leaning towards at least hiding the shelve functionality when the dialog is launched in commit mode, just to avoid confusing new users. But I'm waiting to hear from TK about this. -- Steve ------------------------------------------------------------------------------ This SF.net email is sponsored by: SourcForge Community SourceForge wants to tell your story. http://p.sf.net/sfu/sf-spreadtheword _______________________________________________ Tortoisehg-develop mailing list [email protected] https://lists.sourceforge.net/lists/listinfo/tortoisehg-develop
