When we convert over to the federated marhsallers, I think we can get
rid of AtomicComponent and just have Component. To do this, we would
need to move some of the lifecycle getters such as conversational
lifetime, etc. to Component. The other change we would need to do is
have InstanceWrapper handle init() and destroy() callbacks. I think
we can do this by having the wrapper generated on the controller and
serialized across. This would allow us to eliminate reflection.
Finally, JavaTargetInvoker (should be renamed) would then deal with
InstanceWrappers which it obtained from the ScopeContainer, as
opposed to AtomicComponent.
What do people think?
Jim
---------------------------------------------------------------------
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]