[ 
https://issues.apache.org/jira/browse/TUSCANY-1505?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12519746
 ] 

Frank Budinsky commented on TUSCANY-1505:
-----------------------------------------

Looking at this more closely, I wonder if this is needed at all, since it looks 
like initializeMetaData() also does the same thing.

I think you should look at this whole pattern more carefully. I would suggest a 
test case that has cyclic dependenices, e.g., A.xsd (with an element of a type 
in B.xsd) and B.xsd (with an element of a type in A.xsd).

The key to this is to make sure that all dependent metaobjects are available 
(have been created) by the time they're needed in initializeMetaData().



> Naming scheme used for variables in code gen factory init() method breaks 
> under specific circumstances
> ------------------------------------------------------------------------------------------------------
>
>                 Key: TUSCANY-1505
>                 URL: https://issues.apache.org/jira/browse/TUSCANY-1505
>             Project: Tuscany
>          Issue Type: Bug
>          Components: Java SDO Tools
>    Affects Versions: Java-SDO-1.0
>         Environment: n/a
>            Reporter: David T. Adcox
>            Priority: Minor
>             Fix For: Java-SDO-Next
>
>         Attachments: 1505.patch, test1505.zip
>
>
> A new code gen pattern was recently added to change how dependent packages 
> are initialized in the xxxFactoryImpl.init() method.  Under this new pattern, 
> all dependent packages are initialized via the factoryInterface.INSTANCE 
> method.   An initialization call is made for each dependent gen package.  The 
> getImportedFactoryInterfaceName() is used to retrieve the short name.  This 
> value is mashed with the text 'Instnace' to form a variable name.  If 
> circumstances dictate that multiple packages contain the same factory 
> interface name, the getImportedFactoryInterfaceName() will fully qualify the 
> response instead of using the short name.  This breaks the generated code, 
> due to the use of a '.' in the variable name.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]

Reply via email to