Can anyone explain what I've been reading? I'm trying to understand why
many documents show:
        def myMethod(vars): 
or
        class myClass(var):
and others show:
        def myMetheod(self, vars)
or
        class myClass(self, vars)

Either way seems to work fine, so I'm not sure what it happening.

Also, what is with the double underscores? (__init__ for example) is
this required? or a Pythonic naming convention? When and how to use?

I'm 'trying' to write clear pythonic code since in all reality it gives
a nice polish to the code when compared to writing c style. 

Thanks. 

_______________________________________________
Tutor maillist  -  Tutor@python.org
http://mail.python.org/mailman/listinfo/tutor

Reply via email to