Hey group,

I have a bit of a non-technical question.

I've seen quite a bit recently about the rise of software apprenticeships. As a self-taught developer, this looks quite appealing for a number of reasons. I'm wondering if anyone in the group knows of any apprenticeships (or, if not a formal apprenticeship, a shop that's looking for a very self-motivated Junior Dev that is quite eager to learn, contribute, and be mentored).

I apologize if this is an improper request for this forum.

Many thanks in advance!

Malcolm Newsome
malcolm.news...@gmail.com <mailto:malcolm.news...@gmail.com>





On 09/29/2012 06:16 PM, tutor-requ...@python.org wrote:
Send Tutor mailing list submissions to
        tutor@python.org

To subscribe or unsubscribe via the World Wide Web, visit
        http://mail.python.org/mailman/listinfo/tutor
or, via email, send a message with subject or body 'help' to
        tutor-requ...@python.org

You can reach the person managing the list at
        tutor-ow...@python.org

When replying, please edit your Subject line so it is more specific
than "Re: Contents of Tutor digest..."


Today's Topics:

    1. Re: Lotka-Volterra Model Simulation Questions (Oscar Benjamin)
    2. Re: Lotka-Volterra Model Simulation Questions (Alan Gauld)
    3. Re: Lotka-Volterra Model Simulation Questions (Oscar Benjamin)
    4. Re: Lotka-Volterra Model Simulation Questions (Brett Ritter)
    5. Re: generic repr method? (Oscar Benjamin)


----------------------------------------------------------------------

Message: 1
Date: Sat, 29 Sep 2012 22:20:46 +0100
From: Oscar Benjamin <oscar.j.benja...@gmail.com>
To: Jim Apto <jimmya...@gmail.com>
Cc: tutor@python.org
Subject: Re: [Tutor] Lotka-Volterra Model Simulation Questions
Message-ID:
        <cahvvxxqjqzf74nwhfhb7vovr5o0-s0pyyvtyzumf+lzxqu5...@mail.gmail.com>
Content-Type: text/plain; charset="iso-8859-1"

On 28 September 2012 21:32, Jim Apto <jimmya...@gmail.com> wrote:

Hello folks,

I'm relatively new to python, and was asked to program a lotka-volterra
model (predator and prey relation) simulator.  The program basically will
basically have a menu that takes user input, collect data, and then create
a graph.  Currently i've been working on the simulator section; I can't
seem to get the lists right.

Jim, I apologise if the responses to your original post seem to have gotten
distracted from the problems you're having. Also I'm sorry if my first post
was a bit abstract.

Have the responses so far been helpful?

Oscar
-------------- next part --------------
An HTML attachment was scrubbed...
URL: 
<http://mail.python.org/pipermail/tutor/attachments/20120929/ac95aa50/attachment-0001.html>

------------------------------

Message: 2
Date: Sat, 29 Sep 2012 22:57:09 +0100
From: Alan Gauld <alan.ga...@btinternet.com>
To: tutor@python.org
Subject: Re: [Tutor] Lotka-Volterra Model Simulation Questions
Message-ID: <k47qrk$5er$1...@ger.gmane.org>
Content-Type: text/plain; charset=UTF-8; format=flowed

On 29/09/12 11:42, Steven D'Aprano wrote:
On 29/09/12 19:16, Alan Gauld wrote:
I did say I had no idea about the original algorithm so yes, if the
variable names are industry standardised and the people working with the
  code are familiar with them then it may be better to stick with them,
As to using short names to keep things on a single line, there is a huge
body of research in Comp Science that shows that meaningful names
outweigh single line expressions every time in terms of...
Yes, but "meaningful names" is relative to the reader,
Absolutely, see the first para above. This latter comment was explicitly
in response to the snipped (by me) context:

"Also there are good reasons for using short names in equations. It
makes it much easier to see the whole equation at once, which makes it
easier to understand the equations and easier to check your code. If you
make the variable names too long, even simple equations like these will
have to split over several lines and be more difficult to read/check."

To a mathematician, "pi" or "?" is meaningful, and
"constant_ratio_of_diameter_to_circumference" would be much harder to read.
Totally agree.
My point is that we should not choose short names just to keep an
expression on a single line. The evidence suggests that the advantages
of longer names outweigh the advantage of a single line. But in the
cases here where single letters evidently have expressive power in their
own right the familiar term is preferable over a longer descriptive name.

Of course, care is needed when splitting an expression over multi lines
to keep the readability so if the terms can be naturally split by
operator then that's the place to split them. But this is the same in
written math too. (Most of the equations I remember reading from my
quantum mechanics days were split over at least 3 lines... trying to
force them into a single line would not have made them any more palatable!)

p = m*v*(1-(c/v)**2)**-0.5

they aren't likely to be much enlightened by:

momentum = rest_mass*velocity*(1-(speed_of_light/velocity)**2)**-0.5
I'm slightly less convinced by that. I rarely learned Physics formulae
by wrote  because I could usually work them out from first principles
easily enough. So knowing what the variables represent would help me
more than an equation of single letters if it was an equation I hadn't
seen before. But where it is an industry standard equation using
industry standard symbols then for sure, stick to the standard.

and of course, the longer names aren't likely to help the programmer find
the bug in the expression if he doesn't know the subject well.
Agreed, but if he knows the subject area but not the specific algorithm
it might help (again assuming standard symbology is used appropriately).

Meaningful names are vital. But short names, even single letters, are not
necessarily less meaningful than longer, more descriptive names.
Absolutely.


_______________________________________________
Tutor maillist  -  Tutor@python.org
To unsubscribe or change subscription options:
http://mail.python.org/mailman/listinfo/tutor

Reply via email to