On 04/10/2013 11:53 AM, Tom Warren wrote:
> As suggested by Stephen Warren, use tegra_get_chip() to return
> the pure CHIPID for a Tegra SoC (i.e. 0x20 for Tegra20, 0x30 for
> Tegra30, etc.) and rename tegra_get_chip_type() to reflect its true
> function, i.e. tegra_get_chip_sku(), which returns an ID like
> TEGRA_SOC_T25, TEGRA_SOC_T33, etc.

> diff --git a/arch/arm/cpu/arm720t/tegra-common/cpu.c 
> b/arch/arm/cpu/arm720t/tegra-common/cpu.c

> +     /* get SOC (chip) type */
> +     soc_type = tegra_get_chip();

> +     /* adjust PLLP_out1-4 on T3x/T114 */
> +     if (soc_type >= CHIPID_TEGRA30) {

In the long run, I doubt >= will work here, since there's probably no
guarantee that newer chips will have larger chipid values. However, it's
fine for the chips we currently support.

Reviewed-by: Stephen Warren <swar...@nvidia.com>
_______________________________________________
U-Boot mailing list
U-Boot@lists.denx.de
http://lists.denx.de/mailman/listinfo/u-boot

Reply via email to