Since commit 44c6e6591cb451ae606f8bde71dd5fb7b4002544
"rename _end to __bss_end__" , the _end was removed.
But we need it now for separated device tree control,
ie, CONFIG_OF_SEPARATE .

The _end is used by fdtdec_setup() to find the blob.

Signed-off-by: Thomas Chou <tho...@wytron.com.tw>
Acked-by: Marek Vasut <ma...@denx.de>
Reviewed-by: Simon Glass <s...@chromium.org>
---

v3 comment coding style fix

 arch/nios2/cpu/u-boot.lds | 6 ++++++
 1 file changed, 6 insertions(+)

diff --git a/arch/nios2/cpu/u-boot.lds b/arch/nios2/cpu/u-boot.lds
index 8b0fd1a..9d13ecc 100644
--- a/arch/nios2/cpu/u-boot.lds
+++ b/arch/nios2/cpu/u-boot.lds
@@ -67,6 +67,12 @@ SECTIONS
        _edata = .;
        PROVIDE (edata = .);
 
+       /*
+        * _end - This is end of u-boot.bin image.
+        * dtb will be appended here to make u-boot-dtb.bin
+         */
+       _end = .;
+
        /* UNINIT DATA - Small uninitialized data is first so it's
         * adjacent to sdata and can be referenced via gp. The normal
         * bss follows. We keep it adjacent to simplify init code.
-- 
2.1.4

_______________________________________________
U-Boot mailing list
U-Boot@lists.denx.de
http://lists.denx.de/mailman/listinfo/u-boot

Reply via email to