Replace the open-coded values with constants to make it clearer what they
mean.

Signed-off-by: Simon Glass <s...@chromium.org>
---

Changes in v2: None

 common/usb_kbd.c | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/common/usb_kbd.c b/common/usb_kbd.c
index 1d85212..069fbd2 100644
--- a/common/usb_kbd.c
+++ b/common/usb_kbd.c
@@ -411,13 +411,13 @@ static int usb_kbd_probe_dev(struct usb_device *dev, 
unsigned int ifnum)
 
        iface = &dev->config.if_desc[ifnum];
 
-       if (iface->desc.bInterfaceClass != 3)
+       if (iface->desc.bInterfaceClass != USB_CLASS_HID)
                return 0;
 
-       if (iface->desc.bInterfaceSubClass != 1)
+       if (iface->desc.bInterfaceSubClass != USB_SUB_HID_BOOT)
                return 0;
 
-       if (iface->desc.bInterfaceProtocol != 1)
+       if (iface->desc.bInterfaceProtocol != USB_PROT_HID_KEYBOARD)
                return 0;
 
        if (iface->desc.bNumEndpoints != 1)
@@ -626,8 +626,8 @@ static const struct usb_device_id kbd_id_table[] = {
                        USB_DEVICE_ID_MATCH_INT_SUBCLASS |
                        USB_DEVICE_ID_MATCH_INT_PROTOCOL,
                .bInterfaceClass = USB_CLASS_HID,
-               .bInterfaceSubClass = 1,
-               .bInterfaceProtocol = 1,
+               .bInterfaceSubClass = USB_SUB_HID_BOOT,
+               .bInterfaceProtocol = USB_PROT_HID_KEYBOARD,
        },
        { }             /* Terminating entry */
 };
-- 
2.6.0.rc2.230.g3dd15c0

_______________________________________________
U-Boot mailing list
U-Boot@lists.denx.de
http://lists.denx.de/mailman/listinfo/u-boot

Reply via email to