Dear Delio Brignoli,

In message <15866eae-624b-4850-b10f-78ab99e3a...@audioscience.com> you wrote:
> 
> On 21/05/2010, at 15:13, Wolfgang Denk wrote:
> >> +                          *rxp = buf_reg_val & 0xFF;      
> >> +                          rxp++;
> >> +                  }
> > 
> > Please change into:
> > 
> >                     if (rxp)
> >                             *rxp++ = buf_reg_val & 0xFF;
>
> Are you sure? Is folding that 3 line block into a one liner really worth
> the loss of readability? I know what that means, so do you and many
> others on this ML, but that's bound to raise a few eyebrows. A quick

Removing the need for braces is a good thing.

This is plain C, without any tricks or loopholes.

> in a case like this. In the end it's your decision: if you like to be
> kinky, it's your prerogative ;-)

Kinky?  Funny how you see that.

Best regards,

Wolfgang Denk

-- 
DENX Software Engineering GmbH,     MD: Wolfgang Denk & Detlev Zundel
HRB 165235 Munich, Office: Kirchenstr.5, D-82194 Groebenzell, Germany
Phone: (+49)-8142-66989-10 Fax: (+49)-8142-66989-80 Email: w...@denx.de
Build a system that even a fool can use and only a fool will want  to
use it.
_______________________________________________
U-Boot mailing list
U-Boot@lists.denx.de
http://lists.denx.de/mailman/listinfo/u-boot

Reply via email to