From: Mitchell Horne <mho...@freebsd.org>

On MIPS, __start marks the entry point to the CONFIG_API demo program.
Change the name to _start, to be consistent with all other
architectures.

Signed-off-by: Mitchell Horne <mho...@freebsd.org>
---
 examples/api/crt0.S | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/examples/api/crt0.S b/examples/api/crt0.S
index 57bba9d851..2f75f5a036 100644
--- a/examples/api/crt0.S
+++ b/examples/api/crt0.S
@@ -42,12 +42,12 @@ syscall:
 #elif defined(CONFIG_MIPS)
 #include <asm/asm.h>
        .text
-       .globl __start
-       .ent __start
-__start:
+       .globl _start
+       .ent _start
+_start:
        PTR_S   $sp, search_hint
        b       main
-       .end __start
+       .end _start
 
        .globl syscall
        .ent syscall
-- 
2.26.1

Reply via email to