From: Bin Meng <bin.m...@windriver.com> spl_soc_init() seems to be a better name, as all SPL functions names start from the spl_ prefix.
Signed-off-by: Bin Meng <bin.m...@windriver.com> --- arch/riscv/cpu/fu540/spl.c | 2 +- arch/riscv/include/asm/arch-fu540/spl.h | 2 +- board/sifive/fu540/spl.c | 2 +- 3 files changed, 3 insertions(+), 3 deletions(-) diff --git a/arch/riscv/cpu/fu540/spl.c b/arch/riscv/cpu/fu540/spl.c index a2034e9..45657b7 100644 --- a/arch/riscv/cpu/fu540/spl.c +++ b/arch/riscv/cpu/fu540/spl.c @@ -7,7 +7,7 @@ #include <dm.h> #include <log.h> -int soc_spl_init(void) +int spl_soc_init(void) { int ret; struct udevice *dev; diff --git a/arch/riscv/include/asm/arch-fu540/spl.h b/arch/riscv/include/asm/arch-fu540/spl.h index 0c188be..4697279 100644 --- a/arch/riscv/include/asm/arch-fu540/spl.h +++ b/arch/riscv/include/asm/arch-fu540/spl.h @@ -9,6 +9,6 @@ #ifndef _SPL_SIFIVE_H #define _SPL_SIFIVE_H -int soc_spl_init(void); +int spl_soc_init(void); #endif /* _SPL_SIFIVE_H */ diff --git a/board/sifive/fu540/spl.c b/board/sifive/fu540/spl.c index 31d315d..135e118 100644 --- a/board/sifive/fu540/spl.c +++ b/board/sifive/fu540/spl.c @@ -21,7 +21,7 @@ int spl_board_init_f(void) { int ret; - ret = soc_spl_init(); + ret = spl_soc_init(); if (ret) { debug("FU540 SPL init failed: %d\n", ret); return ret; -- 2.7.4