On 12/18/20 8:29 PM, Simon Glass wrote:
On Tue, 15 Dec 2020 at 17:10, Alexandru Gagniuc <mr.nuke...@gmail.com> wrote:

Use the IS_ENABLED() macro to control code flow, instead of the
caveman approach of sprinkling #ifdefs. Code size is not affected, as
the linker garbage-collects unused functions. However, readability is
improved significantly.

Signed-off-by: Alexandru Gagniuc <mr.nuke...@gmail.com>
---
  common/spl/spl_fit.c | 53 ++++++++++++++++++++------------------------
  1 file changed, 24 insertions(+), 29 deletions(-)

I am trying to imagine stick drawings with #ifdefs

                                   #ifdef
                                 #if     #if
                               #if         #if
#if #if
                                 #if     #if
                                   #endif
                          #if        #if        #if
                            #if      #if      #if
                              #if    #if    #if
                                #if  #if  #if
                                   #ifdef
                                   #endif
                                   #endif
                                   #endif
                                   #endif
                                   #endif
                                   #endif
                                   #endif
                                   #endif
                                   #endif
                                   #endif
                                   #endif
                                   #endif
                                   #endif
                                   #endif
                                   #endif
                                   #endif
                                   #endif
                                   #ifdef
                                #if       #if
                              #if           #if
                            #if               #if
                          #if                   #if
                     #endif                      #endif


Reviewed-by: Simon Glass <s...@chromium.org>

Reply via email to