Dear Andreas,

On Monday 01 November 2010, 11:57:14 Andreas Bießmann wrote:
> Am 01.11.2010 um 09:29 schrieb Alexander Stein:
> > Signed-off-by: Alexander Stein <alexander.st...@systec-electronic.com>
> > ---
> > arch/arm/include/asm/arch-at91/at91cap9.h    |   12 ++++++++----
> > arch/arm/include/asm/arch-at91/at91sam9260.h |    7 +++++++
> > arch/arm/include/asm/arch-at91/at91sam9261.h |    4 ++++
> > arch/arm/include/asm/arch-at91/at91sam9263.h |    3 +++
> > arch/arm/include/asm/arch-at91/at91sam9g45.h |    5 +++++
> > arch/arm/include/asm/arch-at91/at91sam9rl.h  |    4 ++++
> > 6 files changed, 31 insertions(+), 4 deletions(-)
> > 
> > --- a/arch/arm/include/asm/arch-at91/at91sam9g45.h
> > +++ b/arch/arm/include/asm/arch-at91/at91sam9g45.h
> > @@ -51,9 +51,14 @@
> > #define AT91SAM9G45_ID_VDEC 30      /* Video Decoder */
> > #define AT91SAM9G45_ID_IRQ0 31      /* Advanced Interrupt Controller */
> > 
> > +#define AT91_USART0_BASE   0xfff8c000
> > +#define AT91_USART1_BASE   0xfff90000
> > +#define AT91_USART2_BASE   0xfff94000
> > +#define AT91_USART3_BASE   0xfff98000
> > #define AT91_EMAC_BASE              0xfffbc000
> > #define AT91_SMC_BASE               0xffffe800
> > #define AT91_MATRIX_BASE    0xffffea00
> > +#define AT91_DBGU_BASE             0xffffee00
> > #define AT91_PIO_BASE               0xfffff200
> > #define AT91_PMC_BASE               0xfffffc00
> > #define AT91_RSTC_BASE              0xfffffd00
> > diff --git a/arch/arm/include/asm/arch-at91/at91sam9rl.h
> > b/arch/arm/include/asm/arch-at91/at91sam9rl.h index 8eb0d4f..ffa6687
> > 100644
> > 
> > 
> > --- a/arch/arm/include/asm/arch-at91/at91sam9rl.h
> > +++ b/arch/arm/include/asm/arch-at91/at91sam9rl.h
> > @@ -44,6 +44,10 @@
> > #define AT91SAM9RL_ID_AC97C 24      /* AC97 Controller */
> > #define AT91SAM9RL_ID_IRQ0  31      /* Advanced Interrupt Controller (IRQ0) 
*/
> > 
> > +#define AT91_US0_BASE              0xfffb0000
> > +#define AT91_US1_BASE              0xfffb4000
> > +#define AT91_US2_BASE              0xfffb8000
> > +#define AT91_US3_BASE              0xfffbc000
> > #define AT91_SDRAMC_BASE    0xffffea00
> > #define AT91_SMC_BASE               0xffffec00
> > #define AT91_MATRIX_BASE    0xffffee00
> 
> can we just use one naming scheme here? I dunno whether it should be
> AT91_USx or AT91_USARTx but it should be the same in any case.

Yes, sure. I justed copied the dfine and reworded it to match the 
AT91_$COMPONENT_BASE scheme. Always using USARTx is fine though.

Best regards,
Alexander Stein
_______________________________________________
U-Boot mailing list
U-Boot@lists.denx.de
http://lists.denx.de/mailman/listinfo/u-boot

Reply via email to