This has the same name as a field in our local private struct, which is
confusing. Change the name to xfer_len instead.

Signed-off-by: Simon Glass <s...@chromium.org>
---

 drivers/usb/emul/sandbox_flash.c | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/drivers/usb/emul/sandbox_flash.c b/drivers/usb/emul/sandbox_flash.c
index 01b2b41cce9..7de752100c8 100644
--- a/drivers/usb/emul/sandbox_flash.c
+++ b/drivers/usb/emul/sandbox_flash.c
@@ -43,7 +43,7 @@ enum {
  * @error:     true if there is an error condition
  * @alloc_len: Allocation length from the last incoming command
  * @transfer_len: Transfer length from CBW header
- * @read_len:  Number of blocks of data left in the current read command
+ * @read_len:  Number of bytes of data left in the current read command
  * @tag:       Tag value from last command
  * @fd:                File descriptor of backing file
  * @file_size: Size of file in bytes
@@ -92,7 +92,7 @@ struct __packed scsi_read10_req {
        u8 lun_flags;
        u32 lba;
        u8 spare;
-       u16 transfer_len;
+       u16 xfer_len;
        u8 spare2[3];
 };
 
@@ -282,7 +282,7 @@ static int handle_ufi_command(struct sandbox_flash_plat 
*plat,
                struct scsi_read10_req *req = (void *)buff;
 
                handle_read(priv, be32_to_cpu(req->lba),
-                           be16_to_cpu(req->transfer_len));
+                           be16_to_cpu(req->xfer_len));
                break;
        }
        default:
-- 
2.37.2.672.g94769d06f0-goog

Reply via email to