Change type of 'tmp' variable from phys_size_t to phys_addr_t and
rename it to 'low' to better describe what the variable represents,
which is either the bootm_low address from environment or start of
DRAM address.

Signed-off-by: Marek Vasut <marek.vasut+rene...@mailbox.org>
---
Cc: Heinrich Schuchardt <xypron.g...@gmx.de>
Cc: Kuninori Morimoto <kuninori.morimoto...@renesas.com>
Cc: Laurent Pinchart <laurent.pinch...@ideasonboard.com>
Cc: Simon Glass <s...@chromium.org>
Cc: Tom Rini <tr...@konsulko.com>
---
V4: New patch
---
 boot/image-board.c | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/boot/image-board.c b/boot/image-board.c
index e3d63745299..13876b79026 100644
--- a/boot/image-board.c
+++ b/boot/image-board.c
@@ -125,8 +125,8 @@ phys_addr_t env_get_bootm_low(void)
 
 phys_size_t env_get_bootm_size(void)
 {
-       phys_size_t tmp, size;
-       phys_addr_t start;
+       phys_addr_t start, low;
+       phys_size_t size;
        char *s = env_get("bootm_size");
 
        if (s)
@@ -140,11 +140,11 @@ phys_size_t env_get_bootm_size(void)
 
        s = env_get("bootm_low");
        if (s)
-               tmp = simple_strtoull(s, NULL, 16);
+               low = simple_strtoull(s, NULL, 16);
        else
-               tmp = start;
+               low = start;
 
-       return size - (tmp - start);
+       return size - (low - start);
 }
 
 phys_size_t env_get_bootm_mapsize(void)
-- 
2.43.0

Reply via email to