On Monday 21 November 2011 18:57:56 Simon Glass wrote:
>  board/Makefile   |   45
>  board/reloc.c    |  101

not to bikeshed, but i don't think we want files in board/.  how about 
board/common/ or board/generic/ instead ?

> --- /dev/null
> +++ b/board/Makefile
>
> +ifndef CONFIG_SYS_LEGACY_BOARD
> +COBJS        += reloc.o
> +endif

i don't think relocation should be tied "legacy board".  not all arches do 
relocation at all, which means they might never opt in to this aspect.

> --- a/include/common.h
> +++ b/include/common.h
>
> -void relocate_code (ulong, gd_t *, ulong) __attribute__ ((noreturn));
> +#include <reloc.h>

i'd think very few funcs would need this.  so maybe we should make the few 
places include reloc.h explicitly.
-mike

Attachment: signature.asc
Description: This is a digitally signed message part.

_______________________________________________
U-Boot mailing list
U-Boot@lists.denx.de
http://lists.denx.de/mailman/listinfo/u-boot

Reply via email to