Hi Mike, On Fri, Feb 3, 2012 at 6:42 AM, Mike Frysinger <vap...@gentoo.org> wrote: > On Thursday 19 January 2012 19:53:29 Joe Hershberger wrote: >> + NetOurGatewayIP = 0; >> + ip_to_string(NetOurGatewayIP, tmp); >> + setenv("gatewayip", tmp); >> + >> + ip_to_string(NetOurSubnetMask, tmp); >> + setenv("netmask", tmp); >> + >> + ip_to_string(NetOurIP, tmp); >> + setenv("ipaddr", tmp); > > i feel like we should add a helper to do this > setenv_ip("ipaddr", NetOurIP);
I think that's a good idea, but I don't think it should be part of this patch series. It would probably be clearer to do that independently later. >> --- a/net/Makefile >> +++ b/net/Makefile >> >> -COBJS := $(COBJS-y) >> +COBJS := $(sort $(COBJS-y)) > > why ? Sort is needed because there are 2 different config options that could add the net_rand source file and sort will eliminate duplicates. -Joe _______________________________________________ U-Boot mailing list U-Boot@lists.denx.de http://lists.denx.de/mailman/listinfo/u-boot