At 18:14 -0600 2006/09/20, Kevin King wrote:
Also, note that I personally prefer the two letter comparators (EQ,
NE, etc.) to improve readability as it provides some differentiation
between the assignment and comparator operators.
Allong these lines, I try to use a technique from my C days: Put the
constant on the left:
"Y" = theVar
This way, if something happens and the boolean context is lost,
you'll get a compiler error and not a hidden assignment that could be
hard to find. It's not as useful because mvBASIC doesn't use == for
comparison and = for assignment, so you're less likely to have and
accidental assigment, but it doesn't hurt, if you can develop the
habit.
Ray
--
.=================================================================.
| =-=-=-=-=-=-= Eagle Rock Information Systems Corp =-=-=-=-=-=-= |
| -=-=-=-=-=-=- web and database business solutions -=-=-=-=-=-=- |
| <http://www.eriscorp.com> <mailto:[EMAIL PROTECTED]> |
|Midwest Regional Office: 815-547-0662 (voice) 815-547-0353 (Fax)|
.=================================================================.
-------
u2-users mailing list
u2-users@listserver.u2ug.org
To unsubscribe please visit http://listserver.u2ug.org/