Hi all,

For Flink to treat a model class as a special POJO type, these are the
documented conditions:
https://nightlies.apache.org/flink/flink-docs-release-1.13/docs/dev/serialization/types_serialization/#pojos

It says the following:

   -

   All fields are either public or must be accessible through getter and
   setter functions. For a field called foo the getter and setter methods
   must be named getFoo() and setFoo().


We have boolean fields in our model class:
public class Input {
      private boolean open;
}

As per this we are forced to create an accessor getOpen( ) while the
standard Javabeans convention would be isOpen().

We ran some tests with both isOpen and getOpen and both seem to be
recognized as POJO.

Could we get confirmation that using isOpen() is valid here? And that this
primitive boolean case is just not been documented in the above link?


Regards,
Mac Pandey

Reply via email to