Jacques

That works fine.  findAll() works for me because I added it back in.
findAll() is a better function to use because in my opinion, it sez exactly
what it does and that makes the code more readable.  I have hundreds of java
files written over the years and it was way easier to add back in the
functionality you guys deprecated/removed than to replace all my entity
engine calls.

This time however, I put them all together so it would be easier next time
you guys do a major release.

BTW, I have had a few weeks now to go pretty thoroughly through lots of this
code and it is very nice.  I am especially pleased with the re-write of the
widget code and the use of jquery.

Skip

-----Original Message-----
From: Jacques Le Roux [mailto:jacques.le.r...@les7arts.com]
Sent: Thursday, May 30, 2013 6:38 AM
To: user@ofbiz.apache.org
Subject: Re: But in CategoryTree.groovy


Thanks for report Skip,

BTW you must have missed something, findAll does not exist anymore for 3
years ;)
http://svn.apache.org/viewvc?view=revision&revision=938947

Using
prodCatalogs = delegator.findList("ProdCatalog", null, null, null, null,
false);
Should be the way. Could you please confirm before I commit?

Thanks

Jacques

From: "Skip" <s...@thedevers.org>
> There is a line at 50 that sez:
>
> prodCatalogs = delegator.findByAnd("ProdCatalog");
>
> This causes a groovy ambiguious error when you go to the catalog screen in
> 12.04.
>
> Changing this to:
> prodCatalogs = delegator.findAll("ProdCatalog");
>
> Fixes the problem.
>
> I expect you guys already did this, there here it is for any others like
me
> that just download the zip file.
>
> Skip
>

Reply via email to