You only need to set the attribute name of the field

<field name="personId" type="text"></input>

You can even use a different Id, if you want to refer to the field in
javascript.  Why does it bother you?

2014-11-05 15:39 GMT-05:00 Paul Benedict <pbened...@apache.org>:

> Let's say I have a getter/setter for field personId. That means in my
> markup, I need to have a field named personId too. However, I am not really
> found of bleeding Java naming conventions into my web page. Shouldn't there
> be a way -- is there a way? -- of assigning another name to it?
>
> Hopeful example:
>
> @RequestParam("person")
> public final void setPersonId(String personId) { ... }
>
> Cheers,
> Paul
>

Reply via email to