I would question anyone who told me I had to use something that is going away in the future (most of Struts' taglibs), instead of using a standard technology (the JSTL).

Are they fully-aware of the decision they're making? Are you running within a container that supports Servlet Specification 2.3 and JSP Specification 1.2?

I can't conceive of anyone being so narrow-minded. If I told my boss I wanted to use the JSTL over Struts' taglibs (a conversation that would never take place because I'm able to do whatever I feel is best), citing that the JSTL was a standard technology and that the Struts taglibs would be going away, he'd thank me for the FYI and tell me to do what I felt was best. We're very into using standards-compliant methodologies where it makes sense to do so though.

Eddie

----- Original Message ----- From: "Janice" <[EMAIL PROTECTED]>
To: "'Struts Users Mailing List'" <[EMAIL PROTECTED]>
Sent: Wednesday, November 03, 2004 1:06 PM
Subject: RE: Need an alternative to bean:define



Thanks Matt, but I think my problem is that I'm using Struts 1.1 (and can't
change it)


According to: http://struts.apache.org/userGuide/struts-bean.html#define

You can't re-define in 1.1.  There must be a workaround?

TIA,
J


-----Original Message----- From: Matt Bathje [mailto:[EMAIL PROTECTED] Sent: Wednesday, November 03, 2004 10:32 AM To: Struts Users Mailing List Subject: Re: Need an alternative to bean:define


Janice -

I do multiple bean:defines (with values, not with name/property
attributes) in some of my jsps, and never have problems, and am
therefore assuming that the name/property attributes are causing the
problem.

Here may be a non-jstl workaround you can try:

<bean:define id="lastClientName">
       <bean:write name="widget" property="clientName" /> <bean:define>



Matt




Janice wrote:
Unfortunately, I need to get all kinds of approval to use JSTL, is
there no Struts tag that will do this?

TIA,
J

-----Original Message-----
From: atta-ur rehman [mailto:[EMAIL PROTECTED]
Sent: Tuesday, November 02, 2004 5:04 PM
To: Struts Users Mailing List
Subject: Re: Need an alternative to bean:define


Is JSTL an option? I find Struts Logic tag hard to read! If so, I think this should do:

<c:set var="lastCN" value=""/>
<logic:iterate...>
<c:if test="${widget.clinetName != lastCN}">
  ....
</c:if>
<c:set var="lastCN" value="${widget.clientName}"/> </logic:iterate>

HTH. Of course this is from top of my head, i haven't tried it.

ATTA

On Tue, 02 Nov 2004 16:16:25 -0800, Janice <[EMAIL PROTECTED]> wrote:

My brain has stopped working.  I need an alternative to bean:define.

What I'm TRYING to do is iterate through a list, displaying a certain
bit of code only when its different than the last iteration
(grouping).

Here's a snip:

       <bean:define id="lastClientName" value="" />

       <logic:iterate id="widget" name="widgets">

       <logic:notEqual name="widget" property="clientName"
value="<%=lastClientName%>">
       <tr>
         <td colspan=all>
           client: <bean:write name="widget" property="clientName" />
         </td>
       </tr>
       <bean:define id="lastClientName" name="widget"
property="clientName" />
       </logic:notEqual>

End of snip.

This won't compile since bean "lastClientName" has already been
defined.  I can't change my version of Struts.

What would be some clean syntax to use instead?

Thanks so much in advance!

J

---------------------------------------------------------------------
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]





--------------------------------------------------------------------- To unsubscribe, e-mail: [EMAIL PROTECTED] For additional commands, e-mail: [EMAIL PROTECTED]



---------------------------------------------------------------------
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]





--- avast! Antivirus: Outbound message clean. Virus Database (VPS): 0445-1, 11/03/2004 Tested on: 11/3/2004 7:16:52 PM avast! - copyright (c) 2000-2004 ALWIL Software. http://www.avast.com




--------------------------------------------------------------------- To unsubscribe, e-mail: [EMAIL PROTECTED] For additional commands, e-mail: [EMAIL PROTECTED]



Reply via email to