Thanks Gary for the pointers. Just to share my experience on the "lockKeepAlivePeriod" - i believe this is the time for which the lock will be help, if we keep it low, then the slave gets chance to connect to DB and then at that time messages reach there, and there is no guarantee of message WRT who is going to process it.
regarding the "On 1) the broker schedular maintains its own file based store, and sends the messages when they are due." So if I have a shared file system between the master and slave and the master goes down the slave will be able to use the messages in the shared file system? ---- So till this issue of master slave lock handover is not cleared properly we cannot have a reliable Master-Slave config with a proper fail over. The reason I am asking is because if we put exclusive lock from master and there is a network glitch, even the slave will not be able to connect to DB and die. I have seen this happening, and was the main concern for me. And in this case of failure, it actually gives System.exit so even the wrapper cannot push it back into action again. regards, Mohan -- View this message in context: http://activemq.2283324.n4.nabble.com/question-about-ActiveMQ-jdbcPersistenceAdapter-and-MasterSlave-tp4653602p4653609.html Sent from the ActiveMQ - User mailing list archive at Nabble.com.
