On 3 January 2015 at 13:14, Jeroen van der Wal <jer...@stromboli.it> wrote:

>
> I have one more thought: since @ViewModel and @DomainObject(nature=UI_VIEW)
> are the same concepts it might be more intuitive to use
> @DomainObject(nature=VIEW_MODEL)
>
>

Yes, that probably does make sense; we are just providing two equivalent
syntaxes for describing a (UI) view model.

So the revised proposal is:

for the UI/app layer, retain/introduce:
* @ViewModel
* @ViewModelLayout

for the domain layer:
* @DomainObject(nature=JDO_ENTITY | EXTERNAL_ENTITY | VIEW_MODEL)
* @DomainObjectLayout

for both:
* @Property(domainEvent=..., ) and @PropertyLayout
* @Collection(domainEvent=..., ) and @CollectionLayout
* @Action(domainEvent=..., ) and @ActionLayout
* @Parameter and @ParameterLayout

where @ViewModel and @DomainObject(nature=VIEW_MODEL) are basically
equivalent; choose whichever notation you prefer (and use a metamodel
validator to exclude the other).


thx
Dan

Reply via email to