>> Just interested to know if there is any way to stop DataNucleus adding 
_oid
>> to the end of all its generated foreign keys, this it with
>> @PersistenceCapable( identityType = IdentityType.DATASTORE)?
>> It adds _id_oid to the tail of them all so wondering why?
>
> Don't know why it does it (it is a rather odd name,  I agree) but iirc you 
can override it using @Column(name=...)

FYI : This is documented at
http://www.datanucleus.org/products/accessplatform_4_2/jdo/orm/datastor
e_identifiers.html

The JPA spec defines what column names should default to. 
The JDO spec does not, so DataNucleus provides 4 alternatives (default = 
"datanucleus2"), but you also have "jpa", "datanucleus1" and (for those 
with very old code) "jpox".

And if sufficiently interested in there being a JDO spec definition of the 
default then kindly participate in Apache JDO issue
https://issues.apache.org/jira/browse/JDO-727


Regards
-- 
Andy
DataNucleus (Web: http://www.datanucleus.org   Twitter: @datanucleus)

Reply via email to