Hi,

 

Quick one. I have just installed a vanilla Netbeans 15 and when I write a line such as

 

for (Word word : this.dictionary) {...}

 

Netbeans offers me a Warning / Recommendation

 

`Convert to for (Iterator...) {}'

 

That, if chosen, converts my syntax to

 

for (Iterator<Word> it = this.dictionary.iterator(); it.hasNext();) {...}

 

This is a lot less readable to me and I therefore wanted to turn off this hint.

 

However, The <alt><ret> doesn’t offer the option to disable this hint and I couldn’t find it in the Tools > Options > Editor > Hints (Java) list, although I found lots of other nice hints that I have turned on!  

 

I found this on Stack Overflow

 

https://stackoverflow.com/questions/24263479/netbeans-convert-to-for-iterator-suggestion

 

But that was to do with which one is more efficient and I suspect that the warning is due to the fact that the more verbose version is quicker if the number of elements in the iterator is very large.

 

Am I stuck with this, or is it that I just overlooked where the hint is in the long list?

 

 

John

 

--------------------------------------------------------------------- To unsubscribe, e-mail: users-unsubscr...@netbeans.apache.org For additional commands, e-mail: users-h...@netbeans.apache.org For further information about the NetBeans mailing lists, visit: https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists

Reply via email to