Hi,
 when using a ListView, the name uses the following format to Render. <loop
name>:<index>:<field id>

In onSubmit(..); this is fine if you know the order of the list. However say
if the primary data Structure is a hashmap then its more convenient/elegant
to retrieve by Name. I can change the name of the attribute but Wicket does
not recognize it when one does get(<componentId>).

Using ListView.getList() I can access the Model, but this does not help
getting the access to the individual components.

Looks like the only way is to use a numberic counter and construct the
Component ID's to access it one my one.

Is there a way to change the component Id ..or perhaps access these by name?
-- 
View this message in context: 
http://apache-wicket.1842946.n4.nabble.com/Changing-Accessing-name-of-ListItem-in-ListView-tp3218777p3218777.html
Sent from the Users forum mailing list archive at Nabble.com.

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscr...@wicket.apache.org
For additional commands, e-mail: users-h...@wicket.apache.org

Reply via email to