Comments addressed. PTAL.

https://codereview.chromium.org/516853002/diff/1/src/compiler/js-typed-lowering.cc
File src/compiler/js-typed-lowering.cc (right):

https://codereview.chromium.org/516853002/diff/1/src/compiler/js-typed-lowering.cc#newcode502
src/compiler/js-typed-lowering.cc:502: FieldAccess
JSTypedLowering::FieldAccessForElements() {
On 2014/08/28 09:45:09, titzer wrote:
Let's pull these out to an AccessHelper class.

Done. I called it just "Access" but I am happy to change the name if you
want.

https://codereview.chromium.org/516853002/diff/1/src/compiler/js-typed-lowering.cc#newcode566
src/compiler/js-typed-lowering.cc:566: element_access =
ElementAccessForTypedArray(kUntaggedBase, type, 0);
On 2014/08/28 09:45:10, titzer wrote:
Maybe instead of passing the header size, you pass the externalness of
the
elements kind to this method?

Done.

https://codereview.chromium.org/516853002/diff/1/src/compiler/pipeline.cc
File src/compiler/pipeline.cc (right):

https://codereview.chromium.org/516853002/diff/1/src/compiler/pipeline.cc#newcode252
src/compiler/pipeline.cc:252: PhaseStats lowering_stats(info(),
PhaseStats::CREATE_GRAPH,
On 2014/08/28 09:45:10, titzer wrote:
PhaseStats should probably be OPTIMIZATION?

Done.

https://codereview.chromium.org/516853002/diff/1/src/compiler/pipeline.cc#newcode262
src/compiler/pipeline.cc:262: graph_reducer.AddReducer(&simple_reducer);
On 2014/08/28 09:45:10, titzer wrote:
Can you leave a TODO for me here? I am not sure if running them all as
one big
reducer pipeline is best. Have to think about it.

Done.

https://codereview.chromium.org/516853002/

--
--
v8-dev mailing list
v8-dev@googlegroups.com
http://groups.google.com/group/v8-dev
--- You received this message because you are subscribed to the Google Groups "v8-dev" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to v8-dev+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to