https://codereview.chromium.org/668143003/diff/80001/src/ast-numbering.cc
File src/ast-numbering.cc (right):

https://codereview.chromium.org/668143003/diff/80001/src/ast-numbering.cc#newcode48
src/ast-numbering.cc:48: properties_.flags()->Add(kDontSelfOptimize);
Can we delegate between all these helpers and rely on inlining for
performance? This would make the implications much clearer. In this
case:

   dont_crankshaft_reason_ = reason;
   DisableSelfOptimization();

https://codereview.chromium.org/668143003/diff/80001/src/ast-numbering.cc#newcode59
src/ast-numbering.cc:59: properties_.add_node_count(1);
Huh? Why do we increment again here (and in DisableCaching)? This looks
wrong...

https://codereview.chromium.org/668143003/diff/80001/src/compiler.cc
File src/compiler.cc (right):

https://codereview.chromium.org/668143003/diff/80001/src/compiler.cc#newcode581
src/compiler.cc:581: static void
MaybeDisableOptimization(Handle<SharedFunctionInfo> shared_info,
I think this should be folded into DisableOptimization, which should
probably be renamed then. Hmmm, SetBailoutReason makes sense, but we
already have set_bailout_reason in that class (with a getter
DisableOptimizationReason, *very* consistent naming :-P). OK, so my
proposal would be:

   * Rename DisableOptimization to SetBailoutReason and include the
kNoReason handling there.

   * Rename set_bailout_reason to set_disable_optimization_reason and
DisableOptimizationReason to disable_optimization_reason.

https://codereview.chromium.org/668143003/

--
--
v8-dev mailing list
v8-dev@googlegroups.com
http://groups.google.com/group/v8-dev
--- You received this message because you are subscribed to the Google Groups "v8-dev" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to v8-dev+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to