https://codereview.chromium.org/1108563002/diff/60001/src/compiler/instruction-selector.cc
File src/compiler/instruction-selector.cc (right):

https://codereview.chromium.org/1108563002/diff/60001/src/compiler/instruction-selector.cc#newcode1046
src/compiler/instruction-selector.cc:1046: static Node*
DetectTailCall(Node* ret) {
Nit: Use anonymous namespace instead of static, and rename to something
like TryMatchTailCall.

https://codereview.chromium.org/1108563002/diff/60001/src/compiler/instruction-selector.cc#newcode1062
src/compiler/instruction-selector.cc:1062: ?
(NodeProperties::GetControlInput(control, 0) == call)
Urghs, can we please not nest tenary operators?

https://codereview.chromium.org/1108563002/diff/60001/src/compiler/linkage.h
File src/compiler/linkage.h (right):

https://codereview.chromium.org/1108563002/diff/60001/src/compiler/linkage.h#newcode68
src/compiler/linkage.h:68: kIsTailCallAllowed = 1u << 4,
Can we rename this to kSupportsTailCalls?

https://codereview.chromium.org/1108563002/diff/60001/src/compiler/linkage.h#newcode116
src/compiler/linkage.h:116: bool IsTailCallAllowed() const { return
flags() & kIsTailCallAllowed; }
SupportsTailCalls?

https://codereview.chromium.org/1108563002/diff/60001/src/compiler/x64/code-generator-x64.cc
File src/compiler/x64/code-generator-x64.cc (right):

https://codereview.chromium.org/1108563002/diff/60001/src/compiler/x64/code-generator-x64.cc#newcode530
src/compiler/x64/code-generator-x64.cc:530: void
CodeGenerator::FixFrameForTailCall() {
Hm, FixFrameForTailCall is not an appropriate name. How about
AssembleDeconstructActivationRecord?

https://codereview.chromium.org/1108563002/diff/60001/src/compiler/x64/code-generator-x64.cc#newcode541
src/compiler/x64/code-generator-x64.cc:541: __ popq(Operand(rsp,
bytes_to_pop));
Had to close my eyes to review these lines of code...

https://codereview.chromium.org/1108563002/

--
--
v8-dev mailing list
v8-dev@googlegroups.com
http://groups.google.com/group/v8-dev
--- You received this message because you are subscribed to the Google Groups "v8-dev" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to v8-dev+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to