lgtm



https://codereview.chromium.org/1259283002/diff/1/src/parser.cc
File src/parser.cc (right):

https://codereview.chromium.org/1259283002/diff/1/src/parser.cc#newcode2222
src/parser.cc:2222: !scope_->is_declaration_scope() ? LET : VAR;
On 2015/08/04 15:31:19, rossberg wrote:
On 2015/08/03 18:43:51, adamk wrote:
> This looks unrelated to the rest of the change; maybe it's further
fixup from
> the broadening of declaration scope definition?

You are right, I overlooked this one when splitting up the CL. It is
needed
because there was some test started failing with this CL otherwise. I
can
separate it out if you want.

Given that the rest of this change is needed to exercise it
(apparently), I guess splitting it out is more trouble than it's worth.
Just keep an eye on it if this change has to be reverted for other
reasons.

https://codereview.chromium.org/1259283002/diff/40001/src/parser.h
File src/parser.h (right):

https://codereview.chromium.org/1259283002/diff/40001/src/parser.h#newcode556
src/parser.h:556: const Parameter& at(int i) const { return params[i]; }
On 2015/08/04 16:46:25, caitp wrote:
minor question: Is there a sort of system in place for deciding
whether to name
methods with PascalCase vs camelCase vs snake_case? All three seem to
be used in
V8, sometimes within the same classes (as here). The style-guide
doesn't seem
super clear on this.

camelCase shouldn't be used in C++ (and I can't think of a place where
it is), though we do use it in JS. For the other two, see this bit of
the Google C++ style guide:

https://google-styleguide.googlecode.com/svn/trunk/cppguide.html#Function_Names

Short answer: trivial inlined members (such as getters/setters, or this
at() case) may have snake_case names (the idea being to signal that they
are trivial). Any non-trivial method uses PascalCase.

https://codereview.chromium.org/1259283002/diff/40001/src/preparser.h
File src/preparser.h (right):

https://codereview.chromium.org/1259283002/diff/40001/src/preparser.h#newcode1329
src/preparser.h:1329: int Arity() const { return arity; }
This upper/lower thing is a bit confusing now, but I like the
abstraction better. Perhaps this will actually become more classlike in
the future to make the naming less wonky.

https://codereview.chromium.org/1259283002/

--
--
v8-dev mailing list
v8-dev@googlegroups.com
http://groups.google.com/group/v8-dev
--- You received this message because you are subscribed to the Google Groups "v8-dev" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to v8-dev+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to