I like the fact that the heap.h interface is clear of the protected section, +1 on that. As for the cctest structure, I don't have a strong opinion. I would be
fine with it, Benedikt might have a strong opinion on that.


https://codereview.chromium.org/1293283003/diff/20001/test/cctest/test-heap.h
File test/cctest/test-heap.h (right):

https://codereview.chromium.org/1293283003/diff/20001/test/cctest/test-heap.h#newcode5
test/cctest/test-heap.h:5: #ifndef TEST_HEAP_H_
The name of this file is misleading, it looks like this header is
specific to test-heap.cc when it is actually the thing providing the
HeapTester class. Can we either move all of this into cctest.h or call
this file heap-tester.h instead?

https://codereview.chromium.org/1293283003/

--
--
v8-dev mailing list
v8-dev@googlegroups.com
http://groups.google.com/group/v8-dev
--- You received this message because you are subscribed to the Google Groups "v8-dev" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to v8-dev+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to