Renamed ScopeInfoObject to SerializedScopeInfo (discussed with Mads).


http://codereview.chromium.org/2908009/diff/1/15
File src/objects-inl.h (right):

http://codereview.chromium.org/2908009/diff/1/15#newcode2650
src/objects-inl.h:2650: ScopeInfoObject*
SharedFunctionInfo::scope_info() {
On 2010/07/14 08:53:49, Mads Ager wrote:
Why can't you use

ACCESSORS(SharedFunctionInfo, scope_info, ScopeInfoObject,
kScopeInfoOffset)?

Oh, I tried that. ACCESSORS does not work with forward-declared classes
(it wants to use ScopeInfoObject::cast), and if I try to declare
ScopeInfoObject properly there are all kinds of problems with circular
dependencies (scopeinfo.h includes variables.h which includes handles.h
etc). This is the least messy way out.

http://codereview.chromium.org/2908009/diff/1/16
File src/scopeinfo.cc (right):

http://codereview.chromium.org/2908009/diff/1/16#newcode332
src/scopeinfo.cc:332: // For variables allocated in the context they are
always preceded by the
On 2010/07/14 08:53:49, Mads Ager wrote:
by the number Context... number of fixed allocated
->
by Context... fixed allocated

Done.

http://codereview.chromium.org/2908009/diff/1/16#newcode368
src/scopeinfo.cc:368: // +2 for function name and calls eval:
On 2010/07/14 08:53:49, Mads Ager wrote:
: -> .

Done.

http://codereview.chromium.org/2908009/diff/1/16#newcode376
src/scopeinfo.cc:376: int n;  // number of context slots;
On 2010/07/14 08:53:49, Mads Ager wrote:
Call this number_of_context_slots instead of having a comment?

Done.

http://codereview.chromium.org/2908009/diff/1/16#newcode385
src/scopeinfo.cc:385: int n;  // number of parameter slots;
On 2010/07/14 08:53:49, Mads Ager wrote:
Call the variable number_of_parameter_slots instead of the comment?

Done.

http://codereview.chromium.org/2908009/diff/1/16#newcode393
src/scopeinfo.cc:393: // +1 for function name:
On 2010/07/14 08:53:49, Mads Ager wrote:
: -> .

Done.

http://codereview.chromium.org/2908009/diff/1/16#newcode406
src/scopeinfo.cc:406: int n;  // number of stack slots;
On 2010/07/14 08:53:49, Mads Ager wrote:
Argh. I know this is not your changes at all. But could you rename
these
variables instead of having to need the comments. That would be a nice
cleanup
and there are more below.

Done.

http://codereview.chromium.org/2908009/diff/1/16#newcode458
src/scopeinfo.cc:458: // slots start after length entry
On 2010/07/14 08:53:49, Mads Ager wrote:
Capitalize comment and end with period.

Done.

http://codereview.chromium.org/2908009/diff/1/16#newcode462
src/scopeinfo.cc:462: Object** pn = p0 + n * 2;
On 2010/07/14 08:53:49, Mads Ager wrote:
Better names for variables would be nice. pn -> end or
last_context_entry or
something.

Done.

http://codereview.chromium.org/2908009/show

--
v8-dev mailing list
v8-dev@googlegroups.com
http://groups.google.com/group/v8-dev

Reply via email to