On Mon, 9 Mar 2026 13:09:47 GMT, Erik Joelsson <[email protected]> wrote:
>> I added a couple of lines of docs in JavaCompilation.gmk (please take a >> look) but also am now wondering about the naming inconsistency between >> "CLASSPATH" and "PROCESSOR_PATH". Do you want me to change it to >> "PROCESSORPATH" ? > > I don't have a concern for the name. IMO "CLASSPATH" is a special case for > historical reasons, it's just common practice to write it as one word. This > variable represents an option where the words are separated. > > I have a minor concern about modifying the external parameter variable. That > is something we try to avoid (though I'm sure there are other instances > present if you look closely). It would be better if there was a separate > internal variable that was constructed in the macro and then used. I think this is now using only "good practice" in terms of the Makefile changes. Please take another look. ------------- PR Review Comment: https://git.openjdk.org/valhalla/pull/2180#discussion_r3117015024
