> VM_PrintClassLayout uses the wrong VMOp_Type. > > Probably a copy paste error. Uses `VMOp_PrintClassHierarchy` instead of > `VMOp_ClassPrintLayout`. > > --------- > - [x] I confirm that I make this contribution in accordance with the [OpenJDK > Interim AI Policy](https://openjdk.org/legal/ai).
Axel Boldt-Christmas has updated the pull request with a new target base due to a merge or a rebase. The incremental webrev excludes the unrelated changes brought in by the merge/rebase. The pull request contains five additional commits since the last revision: - Rename symbols to be consistent with the CMD `VM.class_print_layout` - Revert "Fix the VMOp name" This reverts commit 617c434d8ed1ccf69e9d3aeb6d25de3fce12b09a. - Merge remote-tracking branch 'upstream_valhalla/lworld' into lworld-wrong-vmop-type - Fix the VMOp name - VM_PrintClassLayout uses the wrong VMOp_Type ------------- Changes: - all: https://git.openjdk.org/valhalla/pull/2401/files - new: https://git.openjdk.org/valhalla/pull/2401/files/617c434d..3b24de1e Webrevs: - full: https://webrevs.openjdk.org/?repo=valhalla&pr=2401&range=02 - incr: https://webrevs.openjdk.org/?repo=valhalla&pr=2401&range=01-02 Stats: 22306 lines in 619 files changed: 16595 ins; 2989 del; 2722 mod Patch: https://git.openjdk.org/valhalla/pull/2401.diff Fetch: git fetch https://git.openjdk.org/valhalla.git pull/2401/head:pull/2401 PR: https://git.openjdk.org/valhalla/pull/2401
