On Wed, 20 May 2026 02:06:43 GMT, Dean Long <[email protected]> wrote:

>> Tobias Hartmann has updated the pull request incrementally with one 
>> additional commit since the last revision:
>> 
>>   Better name
>
> src/hotspot/share/ci/ciMethod.cpp line 669:
> 
>> 667: // MDO updates are racy. C2 can observe the array type before the 
>> profiling code has updated the
>> 668: // corresponding flat/null-free flags. If the array type is known, 
>> prefer the properties it provides.
>> 669: static void sanitize_array_access_profile(ciKlass* array_type, bool& 
>> flat_array, bool& null_free_array) {
> 
> Having "sanitize" in the name feels like it implies a level of confidence in 
> the values that isn't really warranted.  We can miss flags updates as well as 
> type updates, so the combined result is still best effort, therefore I would 
> not call it sanitized.  Maybe something like "update_flags_from_type" is 
> closer to the truth?

I agree and renamed the method accordingly.

-------------

PR Review Comment: 
https://git.openjdk.org/valhalla/pull/2452#discussion_r3271307214

Reply via email to