On Wed, 1 Jul 2026 10:27:21 GMT, Christian Hagedorn <[email protected]> 
wrote:

>> The provided test cases fail when inlining the `Array.copyOf/copyOfRange()` 
>> intrinsics where the source array is flat and from an abstract value class.
>> 
>> The current code checks whether the source array or the destination array 
>> klass contain oops by assuming that a flat value class array is always 
>> concrete and thus an `InlineKlass` (i.e. can call `inline_klass()`). 
>> However, we could also have abstract value class arrays that are known to be 
>> flat (see test cases). This leads to a cast assertion failure because 
>> abstract value classes are represented by an `InstanceKlass` and not an 
>> `InlineKlass`.
>> 
>> To fix this, I added a simple bailout when detecting an abstract flat value 
>> class array. This is a conservative correctness fix and should be revisited 
>> again post-Valhalla-integration. We have 
>> [JDK-8251971](https://bugs.openjdk.org/browse/JDK-8251971) in place for that 
>> which should also tackle other issues around the arraycopy intrinsics and 
>> also address performance problems.
>> 
>> Thanks,
>> Christian
>> 
>> ---------
>> - [x] I confirm that I make this contribution in accordance with the 
>> [OpenJDK Interim AI Policy](https://openjdk.org/legal/ai).
>
> Christian Hagedorn has updated the pull request with a new target base due to 
> a merge or a rebase. The incremental webrev excludes the unrelated changes 
> brought in by the merge/rebase. The pull request contains 11 additional 
> commits since the last revision:
> 
>  - Add test for void.class as well
>  - Improve comments
>  - Merge branch 'lworld' into JDK-8382226
>  - Update
>  - Merge branch 'lworld' into JDK-8382226
>  - Fix endless deopts with -XX:-UseArrayFlattening
>  - Update
>  - improve checks and further refactor exclude_flat to make it easier to read
>  - fix tklass
>  - Review Quan-Anh
>  - ... and 1 more: 
> https://git.openjdk.org/valhalla/compare/42185227...20cd9217

Looks good to me too. Nice tests!

-------------

Marked as reviewed by thartmann (Committer).

PR Review: 
https://git.openjdk.org/valhalla/pull/2569#pullrequestreview-4618233060

Reply via email to